summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-08 13:07:53 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:30 -0400
commit20e65563f0d77347932471a5df5b5f39461ac460 (patch)
treef8013d8be01e1d95aaf0aa81d594af82ab83d9d0
parent7da89252e604db5fdf9962c97402832b72fc870b (diff)
downloadguix-20e65563f0d77347932471a5df5b5f39461ac460.tar.gz
gnu: glib-networking: Disable openssl support.
Revert openssl support enabled in 75acb1b8c4be8c5bbfccc02bf4e76fa9c14976ff,
as GnuTLS is preferred over OpenSSL in Guix.

* gnu/packages/gnome.scm (glib-networking)[arguments](openssl): Remove flag.
[inputs]: Remove openssl.
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ae9ad83680..801f4dd834 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4784,8 +4784,6 @@ library.")
                (base32
                 "0vlzn8jf4sg90cm8xxr28yf66nhf8qy9dl2m4b8w1cr6mn2mw8qb"))))
     (build-system meson-build-system)
-    (arguments
-     `(#:configure-flags '("-Dopenssl=auto")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
@@ -4793,8 +4791,7 @@ library.")
      `(("glib" ,glib)
        ("gnutls" ,gnutls)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-       ("libproxy" ,libproxy)
-       ("openssl" ,openssl)))
+       ("libproxy" ,libproxy)))
     (home-page "https://wiki.gnome.org/Projects/GLib")
     (synopsis "Network extensions for GLib")
     (description