summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-09-06 17:47:54 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-06 18:35:52 -0400
commit3a5df46ef4579b13b667feb4665c76d4c5ee9f01 (patch)
treef0ad4024c0282836997ba78721297dd99657d5fc
parentdadb7f7fb255ac1bc9f3ce3c7d925d8e37ae9364 (diff)
downloadguix-3a5df46ef4579b13b667feb4665c76d4c5ee9f01.tar.gz
gnu: gtksourceview: Update to 4.8.1 and change build-system.
* gnu/packages/gtk.scm (gtksourceview)[version]: Update to 4.8.1.
[build-system]: Change from gnu to meson.
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 1bdd6a2ac0..b05529ac98 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -538,7 +538,7 @@ printing and other features typical of a source code editor.")
 (define-public gtksourceview
  (package
    (name "gtksourceview")
-   (version "4.2.0")
+   (version "4.8.1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnome/sources/gtksourceview/"
@@ -546,8 +546,8 @@ printing and other features typical of a source code editor.")
                                  "gtksourceview-" version ".tar.xz"))
              (sha256
               (base32
-               "0xgnjj7jd56wbl99s76sa1vjq9bkz4mdsxwgwlcphg689liyncf4"))))
-   (build-system gnu-build-system)
+               "1hcswszqnsyqzzf5zk8iflxdvkfvvcg89pf6xsqwbyyabwdxfqyi"))))
+   (build-system meson-build-system)
    (arguments
     '(#:phases
       (modify-phases %standard-phases