summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-30 23:23:24 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-30 23:23:24 +0100
commit40b4c6d6063e608a1df4dca8596e9281ca70cb47 (patch)
tree16bf0cd912efb9e2dcdf89097e4fc9e4155e6d12
parent16eb115ef4986f319e6aebb04cefce12bc851e01 (diff)
downloadguix-40b4c6d6063e608a1df4dca8596e9281ca70cb47.tar.gz
gnu: wpa-supplicant: Remove dependency on DBus.
* gnu/packages/admin.scm (wpa-supplicant): Remove dependency on DBUS.
-rw-r--r--gnu/packages/admin.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 3893da3a07..d7cd0b8092 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -689,9 +689,12 @@ commands and their arguments.")
                    (let ((port (open-file ".config" "al")))
                      (display "
       CONFIG_DEBUG_SYSLOG=y
-      CONFIG_CTRL_IFACE_DBUS=y
-      CONFIG_CTRL_IFACE_DBUS_NEW=y
-      CONFIG_CTRL_IFACE_DBUS_INTRO=y
+
+      # TODO: Add a variant of this package with DBus support.
+      #CONFIG_CTRL_IFACE_DBUS=y
+      #CONFIG_CTRL_IFACE_DBUS_NEW=y
+      #CONFIG_CTRL_IFACE_DBUS_INTRO=y
+
       CONFIG_DRIVER_NL80211=y
       CFLAGS += $(shell pkg-config libnl-3.0 --cflags)
       CONFIG_LIBNL32=y
@@ -708,7 +711,9 @@ commands and their arguments.")
     (inputs
      `(("readline" ,readline)
        ("libnl" ,libnl)
-       ("dbus" ,dbus)
+       ;; TODO: Add a variant with DBus support.  This significantly increases
+       ;; the size of its closure since DBus depends on libx11.
+       ;; ("dbus" ,dbus)
        ("openssl" ,o:openssl)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))