summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-27 09:05:15 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-10-19 12:45:40 +0200
commit47f4df157f999a361fb1d37c07a82f2089fffb4d (patch)
treeef32dc7e59b1f00df451e41108c51d7da58bd61d
parent96a320e5c7cb80d613e47eca48ef68641fa3344f (diff)
downloadguix-47f4df157f999a361fb1d37c07a82f2089fffb4d.tar.gz
gnu: drascula: Use make-desktop-entry-file.
* gnu/packages/games.scm (drascula)[arguments]: Do it.
-rw-r--r--gnu/packages/games.scm28
1 files changed, 12 insertions, 16 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 839fc155cd..b5023e1ee7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7556,22 +7556,18 @@ on items and player adaptability for character progression.")
            ;; game, so we borrow SCUMMVM's.
            (let ((apps (string-append out "/share/applications")))
              (mkdir-p apps)
-             (with-output-to-file (string-append apps "/drascula.desktop")
-               (lambda _
-                 (format #t
-                         "[Desktop Entry]~@
-                     Name=Drascula: The Vampire Strikes Back~@
-                     GenericName=Drascula~@
-                     Exec=~a/bin/drascula~@
-                     Icon=~a/share/icons/hicolor/scalable/apps/scummvm.svg~@
-                     Categories=AdventureGame;Game;RolePlaying;~@
-                     Keywords=game;adventure;roleplaying;2D,fantasy;~@
-                     Comment=Classic 2D point and click adventure game~@
-                     Comment[de]=klassisches 2D-Abenteuerspiel in Zeigen-und-Klicken-Manier~@
-                     Comment[fr]=Jeux classique d'aventure pointer-et-cliquer en 2D~@
-                     Comment[it]=Gioco classico di avventura punta e clicca 2D~@
-                     Type=Application~%"
-                         out scummvm))))
+             (make-desktop-entry-file
+              (string-append apps "/drascula.desktop")
+              #:name "Drascula: The Vampire Strikes Back"
+              #:generic-name "Drascula"
+              #:exec (string-append out "/bin/drascula")
+              #:icon (string-append scummvm "/share/icons/hicolor/scalable/apps/scummvm.svg")
+              #:categories '("AdventureGame" "Game" "RolePlaying")
+              #:keywords '("game" "adventure" "roleplaying" "2D" "fantasy")
+              #:comment '((#f "Classic 2D point and click adventure game")
+                          ("de" "Klassisches 2D-Abenteuerspiel in Zeigen-und-Klicken-Manier")
+                          ("fr" "Jeu classique d'aventure pointer-et-cliquer en 2D")
+                          ("it" "Gioco classico di avventura punta e clicca 2D"))))
            #t))))
     (native-inputs
      `(("bash" ,bash)