summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-04-16 00:16:19 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-07-22 11:04:10 +0300
commit5535d5435efd37f21c791af63a185993a6467341 (patch)
tree658d9936c846cd155b4704b0ac76cf3fa81ab942
parentfd8aea010fee199b803c5613ff80212b009cb0d4 (diff)
downloadguix-5535d5435efd37f21c791af63a185993a6467341.tar.gz
gnu: python-abjad: Rename to abjad.
* gnu/packages/music.scm (abjad): Rename from python-abjad.
(python-abjad): Keep as deprecated package.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/music.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6ee3729f9c..7a69baaad8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1562,9 +1562,9 @@ Guile.")
     ;; more than an hour of silence, so double the max silent time.
     (properties `((max-silent-time . 7200)))))
 
-(define-public python-abjad
+(define-public abjad
   (package
-    (name "python-abjad")
+    (name "abjad")
     (version "3.3")
     (source
      (origin
@@ -1613,6 +1613,9 @@ Guile.")
      "This package provides a Python API for building LilyPond files.")
     (license license:expat)))
 
+(define-public python-abjad
+  (deprecated-package "python-abjad" abjad))
+
 (define-public non-sequencer
   ;; The latest tagged release is three years old and uses a custom build
   ;; system, so we take the last commit.