summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-12-30 21:44:21 +0100
committerRoel Janssen <roel@gnu.org>2017-12-30 21:44:21 +0100
commit57fe82c5bd019d5ed2b2674e2d79508a2750a0df (patch)
tree1f24668c463d59d192c7ec6e81b1d40d71b690e0
parent26d107eb0b56e2733638126c9c5628569f897180 (diff)
downloadguix-57fe82c5bd019d5ed2b2674e2d79508a2750a0df.tar.gz
gnu: Add emacs-php-mode.
* gnu/packages/emacs.scm (emacs-php-mode): New variable.
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 862ff74d40..9f80f241b8 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5319,6 +5319,29 @@ constructs.")
 configuration of Chinese fonts.")
     (license license:gpl2+)))
 
+(define-public emacs-php-mode
+  (package
+    (name "emacs-php-mode")
+    (version "20171225.342")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://melpa.org/packages/php-mode-"
+                    version ".tar"))
+              (sha256
+               (base32
+                "1zz682f34v4wsm2dyj1gnrnvsrqdq1cy7j8p6cvc398w2fziyg3q"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/ejmr/php-mode")
+    (synopsis "Major mode for editing PHP code")
+    (description "@code{php-mode} is a major mode for editing PHP source
+code.  It's an extension of C mode; thus it inherits all C mode's navigation
+functionality.  But it colors according to the PHP grammar and indents
+according to the PEAR coding guidelines.  It also includes a couple handy
+IDE-type features such as documentation search and a source and class
+browser.")
+    (license license:gpl3+)))
+
 (define-public emacs-pos-tip
   (package
     (name "emacs-pos-tip")