summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-04 15:14:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-04 15:17:18 +0200
commit6cd9cb0e133c7f93c7d76e7a39e465d6e9a50b68 (patch)
tree6089794be7f0059b6eb1cf86597dac01360e7bb2
parent82c5d929b9d24f6f9f8425959379d4164d48d219 (diff)
downloadguix-6cd9cb0e133c7f93c7d76e7a39e465d6e9a50b68.tar.gz
gnu: python-nbconvert: Simplify build phase.
* gnu/packages/python-xyz.scm (python-nbconvert)[arguments]: Simplify build
phase "fix-paths-and-tests" by using WHICH; remove final boolean and reindent.
-rw-r--r--gnu/packages/python-xyz.scm47
1 files changed, 21 insertions, 26 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1cdce8625f..b6fcbc807a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10832,34 +10832,29 @@ time.")
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-paths-and-tests
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((pandoc (string-append (assoc-ref inputs "pandoc") "/bin/pandoc"))
-                   (texlive-root (string-append (assoc-ref inputs "texlive")))
-                   (xelatex (string-append texlive-root "/bin/xelatex"))
-                   (bibtex (string-append texlive-root "/bin/bibtex")))
-               ;; Use pandoc binary from input.
-               (substitute* "nbconvert/utils/pandoc.py"
-                 (("'pandoc'") (string-append "'" pandoc "'")))
-               ;; Same for LaTeX.
-               (substitute* "nbconvert/exporters/pdf.py"
-                 (("\"xelatex\"") (string-append "\"" xelatex "\""))
-                 (("\"bibtex\"") (string-append "\"" bibtex "\"")))
-               ;; Make sure tests are not skipped.
-               (substitute* (find-files "." "test_.+\\.py$")
-                 (("@onlyif_cmds_exist\\(('(pandoc|xelatex)'(, )?)+\\)") ""))
-              ;; Pandoc is never missing, disable test.
-              (substitute* "nbconvert/utils/tests/test_pandoc.py"
-                (("import os" all) (string-append all "\nimport pytest"))
-                (("(.+)(def test_pandoc_available)" all indent def)
+           (lambda _
+             ;; Use pandoc binary from input.
+             (substitute* "nbconvert/utils/pandoc.py"
+               (("'pandoc'") (string-append "'" (which "pandoc") "'")))
+             ;; Same for LaTeX.
+             (substitute* "nbconvert/exporters/pdf.py"
+               (("\"xelatex\"") (string-append "\"" (which "xelatex") "\""))
+               (("\"bibtex\"") (string-append "\"" (which "bibtex") "\"")))
+             ;; Make sure tests are not skipped.
+             (substitute* (find-files "." "test_.+\\.py$")
+               (("@onlyif_cmds_exist\\(('(pandoc|xelatex)'(, )?)+\\)") ""))
+             ;; Pandoc is never missing, disable test.
+             (substitute* "nbconvert/utils/tests/test_pandoc.py"
+               (("import os" all) (string-append all "\nimport pytest"))
+               (("(.+)(def test_pandoc_available)" all indent def)
                 (string-append indent "@pytest.mark.skip('disabled by guix')\n"
                                indent def)))
-              ; Not installing pyppeteer, delete test.
-              (delete-file "nbconvert/exporters/tests/test_webpdf.py")
-              (substitute* "nbconvert/tests/test_nbconvertapp.py"
-                (("(.+)(def test_webpdf_with_chromium)" all indent def)
+             ;; Not installing pyppeteer, delete test.
+             (delete-file "nbconvert/exporters/tests/test_webpdf.py")
+             (substitute* "nbconvert/tests/test_nbconvertapp.py"
+               (("(.+)(def test_webpdf_with_chromium)" all indent def)
                 (string-append indent "@pytest.mark.skip('disabled by guix')\n"
-                               indent def)))
-             #t)))
+                               indent def)))))
          (replace 'check
            (lambda* (#:key tests? inputs outputs #:allow-other-keys)
              (when tests?
@@ -10869,7 +10864,7 @@ time.")
                (unsetenv "JUPYTER_CONFIG_DIR")
                ;; Tests depend on templates installed to output.
                (setenv "JUPYTER_PATH"
-                      (string-append
+                       (string-append
                         (assoc-ref outputs "out")
                         "/share/jupyter:"
                         (getenv "JUPYTER_PATH")))