summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 11:30:26 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:17 -0400
commit7270cc93efc8b1a33b0fbc019864980ce72fe822 (patch)
treeeb2f8308eb12322ab004f8ec7e7db51ee7a9f278
parent0c47823a1d818bda8cab989bf66d3e75e577191a (diff)
downloadguix-7270cc93efc8b1a33b0fbc019864980ce72fe822.tar.gz
gnu: vala: Fix documentation.
* gnu/packages/gnome.scm (vala) [arguments]<#:phases>['patch-docbook-xml]: New phase.
[native-inputs]: Add docbook-xml and docbook-xsl.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 90a0eba4a3..6398b1a138 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4349,6 +4349,14 @@ passwords in the GNOME keyring.")
      '(#:configure-flags '("--enable-coverage")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-docbook-xml
+           (lambda* (#:key inputs #:allow-other-keys)
+             (with-directory-excursion "doc/manual"
+               (substitute* '("manual.xml" "version.xml.in")
+                 (("http://www.oasis-open.org/docbook/xml/4.4/")
+                  (string-append (assoc-ref inputs "docbook-xml")
+                                 "/xml/dtd/docbook/"))))
+             #t))
          (add-before 'check 'pre-check
            (lambda _
              (setenv "CC" "gcc")
@@ -4358,6 +4366,8 @@ passwords in the GNOME keyring.")
                 (string-append m "$PKG_CONFIG_PATH:"))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
+       ("docbook-xml" ,docbook-xml-4.4)
+       ("docbook-xsl" ,docbook-xsl)
        ("flex" ,flex)
        ("bison" ,bison)
        ("xsltproc" ,libxslt)