summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 19:48:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 19:48:21 +0100
commit7ca49ab57ae3ba80c8ba395d90c046d9220886c8 (patch)
tree7b7922149b0e7d6d218b5abd2f28a48b843d4e6e
parent239716fb0ba0a7cd81f9d59dcf5a2261b8efe4fa (diff)
downloadguix-7ca49ab57ae3ba80c8ba395d90c046d9220886c8.tar.gz
gnu: ribodiff: Fetch sources from git.
* gnu/packages/bioinformatics.scm (ribodiff)[source]: Fetch from git.
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e32bf60e66..088d3f5dcb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -520,13 +520,14 @@ provides the Ribotaper pipeline.")
     (version "0.2.2")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/ratschlab/RiboDiff/"
-                           "archive/v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ratschlab/RiboDiff.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0wpbwmfv05wdjxv7ikm664f7s7p7cqr8jnw99zrda0q67rl50aaj"))))
+         "0x75nlp7qnmm64jasbi6l21f2cy99r2cjyl6b4hr8zf2bq22drnz"))))
     (build-system python-build-system)
     (arguments
      `(#:python ,python-2