summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-05-04 21:07:23 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-05-04 21:30:58 +0200
commit925fe4b3cece17f564c640f536ebcf24c2af2795 (patch)
tree9d4fabcdd654bf339aa41172c6e2f7f96a074736
parent066d05f0839352f94fb6f882778c7054d87314b2 (diff)
downloadguix-925fe4b3cece17f564c640f536ebcf24c2af2795.tar.gz
gnu: coq-coquelicot: Fix for coq 8.8.
* gnu/packages/ocaml.scm (coq-coquelicot)[arguments]: New phase to
remove a deprecated command.
-rw-r--r--gnu/packages/ocaml.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c401d4a003..c55276aa9d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4034,6 +4034,12 @@ part of the distribution.")
                             "/lib/coq/user-contrib/Coquelicot"))
        #:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'fix-coq8.8
+           (lambda _
+             ; appcontext has been removed from coq 8.8
+             (substitute* "theories/AutoDerive.v"
+               (("appcontext") "context"))
+             #t))
          (add-before 'configure 'fix-remake
            (lambda _
              (substitute* "remake.cpp"