summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-04 13:35:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-04 15:40:33 +0200
commit9a40c1d5bb09cf5dda3604125e72e51300f16d77 (patch)
tree20d23f24b7eb26ff58b074a4ddee2cc25299f77f
parent7f540e3ce0eecb1dedf18e51ac6b161a13a2c625 (diff)
downloadguix-9a40c1d5bb09cf5dda3604125e72e51300f16d77.tar.gz
gnu: indi: Respect #:tests?.
* gnu/packages/astronomy.scm (indi)[arguments]: Respect #:tests? in the
'check phase.
-rw-r--r--gnu/packages/astronomy.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0b54122068..5dcb03ee5a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -816,11 +816,12 @@ provide you with detailed information about each pass.")
           (string-append "-DUDEVRULES_INSTALL_DIR=" out "/lib/udev/rules.d")))
        #:phases
        (modify-phases %standard-phases
-         (replace  'check
-           (lambda _
-             (with-directory-excursion "test"
-               (invoke "ctest"))
-             #t))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (with-directory-excursion "test"
+                 (invoke "ctest"))
+               #t)))
          (add-before 'install 'set-install-directories
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))