summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-04 13:49:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-04 13:49:45 +0200
commita33925d122c99eafb6e1e53ab1c122d7245d8a78 (patch)
treecb236c64a793b0304aaf95eea32a3c0fe7e19da0
parentf35d3132654bd1be5c7453f9eb43eb6e9de85a15 (diff)
downloadguix-a33925d122c99eafb6e1e53ab1c122d7245d8a78.tar.gz
gnu: Remove pcre2/fixed.
* gnu/packages/pcre.scm (pcre2/fixed): Remove variable.
(pcre2)[replacement]: Remove.
[source](patches): New field.
* gnu/packages/php.scm (php)[inputs]: Change PCRE2/FIXED to PCRE2.
-rw-r--r--gnu/packages/pcre.scm14
-rw-r--r--gnu/packages/php.scm2
2 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 7385c78b9f..7ab8174ffa 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -89,13 +89,12 @@ POSIX regular expression API.")
 (define-public pcre2
   (package
     (name "pcre2")
-    (replacement pcre2/fixed)
     (version "10.33")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pcre/pcre2/"
                                   version "/pcre2-" version ".tar.bz2"))
-
+              (patches (search-patches "pcre2-fix-jit_match-crash.patch"))
               (sha256
                (base32
                 "1anqi7vpbfzag7imccrc6di1zl5rl63ab7rfpmajpw6d1kzlsl9m"))))
@@ -126,14 +125,3 @@ own native API, as well as a set of wrapper functions that correspond to the
 POSIX regular expression API.")
    (license license:bsd-3)
    (home-page "https://www.pcre.org/")))
-
-(define-public pcre2/fixed
-  ;; PHP >= 7.3.8 requires a fixed version at build time, so make it public
-  ;; and hide it in the UI.
-  (package
-    (inherit pcre2)
-    (source
-     (origin
-       (inherit (package-source pcre2))
-       (patches (search-patches "pcre2-fix-jit_match-crash.patch"))))
-    (properties '((hidden? . #t)))))
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 2411de55c9..497989b781 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -367,7 +367,7 @@
        ("oniguruma" ,oniguruma-5)
        ("openldap" ,openldap)
        ("openssl" ,openssl)
-       ("pcre" ,pcre2/fixed)            ; must be /fixed for tests
+       ("pcre" ,pcre2)
        ("postgresql" ,postgresql)
        ("readline" ,readline)
        ("sqlite" ,sqlite)