summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 16:20:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 16:20:04 +0100
commita6d867fed9d54f8fe650be45ffb781b16f26dc7a (patch)
tree26dc019a5cb474dc41e686f83401ceb7ea207e2e
parent9d0f794229faeb24801d30f20c5df47bc4a03041 (diff)
downloadguix-a6d867fed9d54f8fe650be45ffb781b16f26dc7a.tar.gz
gnu: Add r-sigpathway.
* gnu/packages/bioconductor.scm (r-sigpathway): New variable.
-rw-r--r--gnu/packages/bioconductor.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 656a594d96..59ca93dde8 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2702,3 +2702,25 @@ variances and the random variance model.  As 10s of thousands of mRNAs are
 analyzed in parallell the library performs a number of tests to assure that
 the data set is suitable for such analysis.")
     (license license:gpl3)))
+
+(define-public r-sigpathway
+  (package
+    (name "r-sigpathway")
+    (version "1.50.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (bioconductor-uri "sigPathway" version))
+        (sha256
+          (base32
+            "0pygrla2q2151981gshzv51jnj60h1df3vby5gsxqvxn2pdr4bv3"))))
+    (properties `((upstream-name . "sigPathway")))
+    (build-system r-build-system)
+    (home-page "https://www.pnas.org/cgi/doi/10.1073/pnas.0506577102")
+    (synopsis "Pathway analysis")
+    (description
+     "This package is used to conduct pathway analysis by calculating the NT_k
+and NE_k statistics in a statistical framework for determining whether a
+specified group of genes for a pathway has a coordinated association with a
+phenotype of interest.")
+    (license license:gpl2)))