summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-14 11:25:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-14 11:40:25 +0100
commita717e8a698319424dfce58ce496d5bfb055753d8 (patch)
treea6573737f637cab6363708d60fec99b529b5db37
parent73e3060d576effa1064bd89f23010ded6188ffd4 (diff)
downloadguix-a717e8a698319424dfce58ce496d5bfb055753d8.tar.gz
gnu: python-flake8-2.2.4: Disable tests.
* gnu/packages/python.scm (python-flake8-2.2.4,
  python2-flake8-2.2.4)[arguments]: Set #:tests? #f.
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ee5cbc5e77..6c58403dd6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5795,7 +5795,10 @@ complexity of Python source code.")
             (for-each delete-file-recursively
                       (find-files "." "__pycache__" #:directories? #t))
             (for-each delete-file (find-files "." "\\.pyc$"))
-            #t))))))
+            #t))))
+    (arguments
+     ;; XXX Fails with Python 3.5.
+     '(#:tests? #f))))
 
 (define-public python2-flake8-2.2.4
   (package-with-python2 python-flake8-2.2.4))