summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-12 11:36:08 +0200
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:25 -0400
commitb9f413121a5b604783d64757bd090c5ddbb9d2fd (patch)
tree3fa253ea2b313315f7d255ad879bd8e13f8aea80
parentd9eaa6624fa626d20d115b8daef009875e51c501 (diff)
downloadguix-b9f413121a5b604783d64757bd090c5ddbb9d2fd.tar.gz
gnu: gst-plugins-base: Enable more features.
* gnu/packages/gstreamer.scm (gst-plugins-base)
[inputs]: Add graphene, iso-codes, libgudev, libjpeg-turbo, libpng,
libvisual, mesa, wayland-protocols, wayland.
[native-inputs]: Add gettext-minimal and xorg-server-for-test.
[arguments]: Remove '-Dgl=disabled' from configure flags.  Add pre-check phase.

Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
Co-authored-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/gstreamer.scm37
1 files changed, 30 insertions, 7 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 94737e5c55..4a9d077772 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -559,6 +559,7 @@ This package provides the core library and elements.")
              '()
              `(("orc" ,orc)))))         ;required by gstreamer-audio-1.0.pc
     (inputs
+     ;; TODO: Add libvorbisidec
      `(("cdparanoia" ,cdparanoia)
        ("pango" ,pango)
        ("libogg" ,libogg)
@@ -573,21 +574,43 @@ This package provides the core library and elements.")
        ;; <https://bugs.gnu.org/32360>
        ,@(if (target-64bit?)
              `(("opus" ,opus))
-             '())))
+             '())
+       ("graphene" ,graphene)
+       ("iso-codes" ,iso-codes)
+       ("libgudev" ,libgudev)
+       ("libjpeg" ,libjpeg-turbo)
+       ("libpng" ,libpng)
+       ("libvisual" ,libvisual)
+       ("mesa" ,mesa)
+       ("wayland-protocols" ,wayland-protocols)
+       ("wayland" ,wayland)))
     (native-inputs
-      `(("pkg-config" ,pkg-config)
-        ("glib:bin" ,glib "bin")
-        ("gobject-introspection" ,gobject-introspection)
-        ("python-wrapper" ,python-wrapper)))
+     `(("pkg-config" ,pkg-config)
+       ("glib:bin" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
+       ("python-wrapper" ,python-wrapper)
+       ("gettext" ,gettext-minimal)
+       ("xorg-server" ,xorg-server-for-tests)))
     (arguments
-     `(#:configure-flags '("-Dgl=disabled")
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          ,@%common-gstreamer-phases
          (add-before 'configure 'patch
            (lambda _
              (substitute* "tests/check/libs/pbutils.c"
                (("/bin/sh") (which "sh")))
+             #t))
+         (add-before 'check 'pre-check
+           (lambda _
+             ;; Tests require a running X server.
+             (system "Xvfb :1 +extension GLX &")
+             (setenv "DISPLAY" ":1")
+             ;; Tests write to $HOME.
+             (setenv "HOME" (getcwd))
+             ;; Tests look for $XDG_RUNTIME_DIR.
+             (setenv "XDG_RUNTIME_DIR" (getcwd))
+             ;; For missing '/etc/machine-id'.
+             (setenv "DBUS_FATAL_WARNINGS" "0")
              #t)))))
     (home-page "https://gstreamer.freedesktop.org/")
     (synopsis