summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 10:53:43 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:16 -0400
commitc13fb7cb9b20dad628ff63756357e01b77c72802 (patch)
tree25fbabcf4bec760bbcf9868b1cf7f09895e144f4
parentdf1fffdc198bd96c0b9693acef6de4fde02a70d8 (diff)
downloadguix-c13fb7cb9b20dad628ff63756357e01b77c72802.tar.gz
gnu: gdk-pixbuf: Update to 2.42.4.
* gnu/packages/gtk.scm (gdk-pixbuf) [version]: Update to 2.42.4.
[native-inputs]: Add perl and libxslt.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 28cf2fdc71..43b1fb71f7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -584,7 +584,7 @@ highlighting and other features typical of a source code editor.")
 (define-public gdk-pixbuf
   (package
     (name "gdk-pixbuf")
-    (version "2.42.2")
+    (version "2.42.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -592,7 +592,7 @@ highlighting and other features typical of a source code editor.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "05ggmzwvrxq9w4zcvmrnnd6qplsmb4n95lj4q607c7arzlf6mil3"))))
+                "0k9f9177qxaryaxprwrhqnv5p2gdq4a8i6y05gm98qa8izc5v77y"))))
     (build-system meson-build-system)
     (arguments
      `(#:meson ,meson-0.55
@@ -637,7 +637,9 @@ highlighting and other features typical of a source code editor.")
        ("gettext" ,gettext-minimal)
        ("glib" ,glib "bin")             ; glib-mkenums, etc.
        ("gobject-introspection" ,gobject-introspection) ; g-ir-compiler, etc.
-       ("pkg-config" ,pkg-config)))
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)
+       ("xsltproc" ,libxslt)))
     (synopsis "GNOME image loading and manipulation library")
     (description
      "GdkPixbuf is a library for image loading and manipulation developed