summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 07:42:10 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:15 -0400
commitd4a93831012517838c496847899214f0d305fc84 (patch)
tree2cfa4a792b3e713fd6f1b17ff87ce8dbaf8bd1a9
parent98c6a15f26325832af5bc0a3f2f5ba688963c12e (diff)
downloadguix-d4a93831012517838c496847899214f0d305fc84.tar.gz
gnu: pangomm: Update to 2.48.0.
* gnu/packages/gtk.scm (pango)[version]: Update to 2.48.0.
[build-system]: Change from gnu to meson.
[arguments]<#:glib-or-gtk?>: New argument.
[native-inputs]: Add m4 and mm-common.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm25
1 files changed, 15 insertions, 10 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9a2027ea94..837f799c84 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1351,17 +1351,22 @@ library.")
 (define-public pangomm
   (package
     (name "pangomm")
-    (version "2.42.0")
+    (version "2.48.0")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://gnome/sources/" name "/"
-                                 (version-major+minor version)  "/"
-                                 name "-" version ".tar.xz"))
-             (sha256
-              (base32
-               "0mmzxp3wniaafkxr30sb22mq9x44xckb5d60h1bl99lkzxks0vfa"))))
-    (build-system gnu-build-system)
-    (native-inputs `(("pkg-config" ,pkg-config)))
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version)  "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0y2vyp6azvhrii6rzs89kr08wg8z1p562awyr812131zqdsd83ly"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t))   ; To wrap binaries and/or compile schemas
+    (native-inputs
+     `(("m4" ,m4)
+       ("mm-common" ,mm-common)
+       ("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("cairo" ,cairo)
        ("cairomm" ,cairomm)