summary refs log tree commit diff
diff options
context:
space:
mode:
authorNaga Malleswari <nagamalli@riseup.net>2020-04-24 01:32:33 +0530
committerRicardo Wurmus <rekado@elephly.net>2020-04-24 15:51:38 +0200
commitea43d299fa2071467cb1aec8cf3dc8f0d95b15f7 (patch)
tree0894f77eacb11e2005bc013ff8eb1ecfcf96ff5a
parentfe14871eddf656d574b2634bcf1093614d45d70c (diff)
downloadguix-ea43d299fa2071467cb1aec8cf3dc8f0d95b15f7.tar.gz
gnu: Add r-aws.
* gnu/packages/cran.scm (r-aws): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 12dd6a3e26..f0796891c8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21213,3 +21213,32 @@ is also implemented here.")
 @code{openMP} support as needed in several packages like
 @code{aws}, @code{adimpro}, @code{fmri}, and @code{dwi}.")
     (license license:gpl2+)))
+
+(define-public r-aws
+  (package
+    (name "r-aws")
+    (version "2.4-2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "aws" version))
+       (sha256
+        (base32
+         "1czlsy64nx6j7h1smgb561yyv3f98pwqwglk77yla4mx3fp14bvq"))))
+    (properties
+     `((upstream-name . "aws")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-awsmethods" ,r-awsmethods)
+       ("r-gsl" ,r-gsl)))
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "https://cran.r-project.org/web/packages/aws/")
+    (synopsis "Adaptive weights smoothing")
+    (description
+     "This package provides a collection of R-functions implementing adaptive
+smoothing procedures in 1D, 2D and 3D.  This includes the
+Propagation-Separation approach to adaptive smoothing, the @dfn{Intersecting
+Confidence Intervals} (ICI), variational approaches, and a non-local means
+filter.")
+    (license license:gpl2+)))