summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-24 22:46:44 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:19 -0400
commitece6fb85761eb504ee122c61c9c2bb27d1cc95ca (patch)
tree1dec5fdd8debb974d1db6fbb029a473e5cfaa978
parent2fa45f0e2179a8ea1dea42773b4c31d0d918d5ef (diff)
downloadguix-ece6fb85761eb504ee122c61c9c2bb27d1cc95ca.tar.gz
gnu: atkmm: Enable documentation.
* gnu/packages/gtk.scm (atkmm) [outputs]: Add new output "doc".
[arguments]<#:configure-flags>[-Denable-documentation]: New flag.
[arguments]<#:phases>['move-doc]: New phase.
[native-inputs]: Add graphviz, doxygen.

Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
-rw-r--r--gnu/packages/gtk.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index cacb738f88..8b96bff404 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -76,6 +76,7 @@
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
   #:use-module (gnu packages libffi)
@@ -1442,10 +1443,27 @@ library.")
                (base32
                 "0wwr0663jrqx2klsasffd9wpk3kqnwisj1y3ahdkjdk5hzrsjgy9"))))
     (build-system meson-build-system)
+    (outputs '("out" "doc"))
     (arguments
-     `(#:glib-or-gtk? #t))   ; To wrap binaries and/or compile schemas
+     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
+       #:configure-flags
+       (list
+        "-Dbuild-documentation=true")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'move-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (assoc-ref outputs "doc")))
+               (mkdir-p (string-append doc "/share"))
+               (rename-file
+                (string-append out "/share/doc")
+                (string-append doc "/share/doc"))
+               #t))))))
     (native-inputs
-     `(("m4" ,m4)
+     `(("dot" ,graphviz)
+       ("doxygen" ,doxygen)
+       ("m4" ,m4)
        ("mm-common" ,mm-common)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)