summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-24 10:32:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-24 11:06:00 +0100
commitff248f41cb3ceee8ca1043723d7668076e58f7bb (patch)
treea9a0f8747314da5ca21950acb043d17679b98055
parentd8dc2a7c1e19b4303d08976031a7ce37469c05e2 (diff)
downloadguix-ff248f41cb3ceee8ca1043723d7668076e58f7bb.tar.gz
gnu: r-patchwork: Update to 1.0.0.
* gnu/packages/cran.scm (r-patchwork): Update to 1.0.0.
[source]: Fetch from CRAN.
[native-inputs]: Add r-knitr.
-rw-r--r--gnu/packages/cran.scm46
1 files changed, 21 insertions, 25 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7ebb733bd4..07eeeb7fc7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15583,35 +15583,31 @@ guaranteeing well-connected communities.\" <arXiv:1810.08473>.")
     (license license:gpl3)))
 
 (define-public r-patchwork
-  ;; There has been no public release yet.
-  (let ((commit "fd7958bae3e7a1e30237c751952e412a0a1d1242")
-        (revision "1"))
-    (package
-      (name "r-patchwork")
-      (version (git-version "0.0.1" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/thomasp85/patchwork.git")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "00fq520xwy1ysg4k8x48x9b0yy9wyi8y8zj6dvxjg4bwx0yyp6s4"))))
-      (build-system r-build-system)
-      (propagated-inputs
-       `(("r-ggplot2" ,r-ggplot2)
-         ("r-gtable" ,r-gtable)))
-      (home-page "https://github.com/thomasp85/patchwork")
-      (synopsis "Compose ggplot2 plots")
-      (description
-       "The @code{ggplot2} package provides a strong API for sequentially
+  (package
+    (name "r-patchwork")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "patchwork" version))
+       (sha256
+        (base32
+         "0qrwbcswh7ylrmghi17k6wk7w51cz6mcmvcyyd41hy3m2ywmkywb"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-gtable" ,r-gtable)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/thomasp85/patchwork")
+    (synopsis "Compose ggplot2 plots")
+    (description
+     "The @code{ggplot2} package provides a strong API for sequentially
 building up a plot, but does not concern itself with composition of multiple
 plots.  Patchwork is a package that expands the API to allow for arbitrarily
 complex composition of plots by providing mathmatical operators for combining
 multiple plots.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public r-liger
   (package