summary refs log tree commit diff
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-05-07 05:29:42 +0300
committerLeo Famulari <leo@famulari.name>2017-05-07 15:22:42 -0400
commit86ab11205ed2b5c925ed9c8328736a433b0d933c (patch)
treedd25ac473186fcc09987eb2a6ff921eda9d69a48
parentce949c10e50da6b385938c929c257c5ca421d651 (diff)
downloadguix-86ab11205ed2b5c925ed9c8328736a433b0d933c.tar.gz
gnu: Add python-pytest-httpbin
* gnu/packages/web.scm (python-pytest-httpbin, python2-pytest-httbin): New
variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 935f80210b..efaa1b5742 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4523,3 +4523,32 @@ JSON-encoded.")
 
 (define-public python2-httpbin
   (package-with-python2 python-httpbin))
+
+(define-public python-pytest-httpbin
+  (package
+    (name "python-pytest-httpbin")
+    (version "0.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-httpbin" version))
+       (sha256
+        (base32
+         "1y0v2v7xpzpyd4djwp7ad8ifnlxp8r1y6dfbxg5ckzvllkgridn5"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-httpbin" ,python-httpbin)
+       ("python-pytest" ,python-pytest)))
+    (home-page
+     "https://github.com/kevin1024/pytest-httpbin")
+    (synopsis
+     "Test your HTTP library against a local copy of httpbin")
+    (description
+     "@code{Pytest-httpbin} creates a @code{pytest} fixture that is dependency-injected
+into your tests.  It automatically starts up a HTTP server in a separate thread running
+@code{httpbin} and provides your test with the URL in the fixture.")
+    (license l:expat)))
+
+(define-public python2-pytest-httpbin
+  (package-with-python2 python-pytest-httpbin))