summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-11-12 17:59:16 -0500
committerMark H Weaver <mhw@netris.org>2017-01-11 11:23:29 -0500
commitb4c8c413cab95704b1d73af0ea4fcda61a716043 (patch)
treeed7d2503983d991d122032f3a445cf94aeb12135
parent5e107b22df2cc42cc0e4601a20a3f6749865adb7 (diff)
downloadguix-b4c8c413cab95704b1d73af0ea4fcda61a716043.tar.gz
gnu: mesa: Enable floating point textures.
* gnu/packages/gl.scm (mesa): Add --enable-texture-float to configure flags.
-rw-r--r--gnu/packages/gl.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 0e9b5ddb5f..9a484b7126 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 David Thompson <davet@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -249,6 +250,9 @@ also known as DXTn or DXTC) for Mesa.")
          "--enable-gles2"
          "--enable-gbm"
          "--enable-shared-glapi"
+         ;; Without floating point texture support, drivers such as Nouveau
+         ;; are stuck at OpenGL 2.1 instead of OpenGL 3.0+.
+         "--enable-texture-float"
 
          ;; on non-intel systems, drop i915 and i965
          ;; from the default dri drivers