summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-21 23:21:18 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-14 23:53:33 -0400
commitbe62a1b5a5d0d2c237beae6ddafebe9c6ef887fa (patch)
treefec62a4a1d7020929ddb14d8b5546482e6c75147
parent9049e4d808f241dd88ddcb6a0f74b0766624fb08 (diff)
downloadguix-be62a1b5a5d0d2c237beae6ddafebe9c6ef887fa.tar.gz
gnu: gjs: Update to 1.58.3.
* gnu/packages/gnome.scm (gjs): Update to 1.58.3.
[native-inputs]: Add dconf.
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 54a845ce68..09f672a66d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5815,7 +5815,7 @@ configuration program to choose applications starting on login.")
 (define-public gjs
   (package
     (name "gjs")
-    (version "1.56.2")
+    (version "1.58.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -5823,7 +5823,7 @@ configuration program to choose applications starting on login.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1b5321krn89p3f7s2ik6gpfnc61apzljhlnbqky8c88f7n6832ac"))))
+                "1bkksx362007zs8c31ydygb29spwa5g5kch1ad2grc2sp53wv7ya"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -5853,6 +5853,7 @@ configuration program to choose applications starting on login.")
        ("xmllint" ,libxml2)
        ;; For testing
        ("dbus-launch" ,dbus)
+       ("dconf" ,dconf) ; required to properly store settings
        ("uuidgen" ,util-linux)
        ("xvfb" ,xorg-server-for-tests)))
     (propagated-inputs