summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-23 10:33:21 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-14 23:53:33 -0400
commitdf3e812fe42a13325ca5b223a115fb2d3dbfd446 (patch)
treeb09e99e858f7677d27e5f18be76a70929a22056d
parent4ac325aa9bf8dd237f5b5be7a1523d957be0067f (diff)
downloadguix-df3e812fe42a13325ca5b223a115fb2d3dbfd446.tar.gz
gnu: seahorse: Update to 3.34.
* gnu/packages/gnome.scm (seahorse): Update to 3.34.
[source]: Remove obsolete patch.
* gnu/packages/patches/seahorse-gtk-use-0-on-empty-flags.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm6
-rw-r--r--gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch32
3 files changed, 2 insertions, 37 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5f26f23373..befbb6ee6e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1453,7 +1453,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/scotch-integer-declarations.patch	\
   %D%/packages/patches/screen-hurd-path-max.patch		\
   %D%/packages/patches/sdl-libx11-1.6.patch			\
-  %D%/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch	\
   %D%/packages/patches/seq24-rename-mutex.patch			\
   %D%/packages/patches/sharutils-CVE-2018-1000097.patch		\
   %D%/packages/patches/shadow-hurd-pctrl.patch			\
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 967fa2fce4..b53d2ece64 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3104,7 +3104,7 @@ engineering.")
 (define-public seahorse
   (package
     (name "seahorse")
-    (version "3.32.2")
+    (version "3.34")
     (source
      (origin
        (method url-fetch)
@@ -3113,9 +3113,7 @@ engineering.")
                            version ".tar.xz"))
        (sha256
         (base32
-         "0d8zdzmlz7fjv9xl20zl4ckidf465mvdjnbpxy3k08y9iw423q4x"))
-       (patches (search-patches
-                 "seahorse-gkr-use-0-on-empty-flags.patch"))))
+         "16sfnqrdlr5xx6kixx2ln1mva7nngjlw1k3f5n454vyaigffjh2v"))))
     (build-system meson-build-system)
     (arguments
      '(#:glib-or-gtk? #t
diff --git a/gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch b/gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch
deleted file mode 100644
index 55866d2973..0000000000
--- a/gnu/packages/patches/seahorse-gkr-use-0-on-empty-flags.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Patch from <https://gitlab.gnome.org/GNOME/seahorse/commit/d9db29db567012b7c72e85e1be1fbf55fcc9b667>.
-
-From d9db29db567012b7c72e85e1be1fbf55fcc9b667 Mon Sep 17 00:00:00 2001
-From: Niels De Graef <nielsdegraef@gmail.com>
-Date: Sat, 11 May 2019 09:02:34 +0200
-Subject: [PATCH] gkr: Use 0 on empty flags
-
-A Flags-type variable without any flag set can be replaced with 0, so
-this is a safe thing to do. It also prevents us from having to deal with
-the accidental API break in libsecret (see
-https://gitlab.gnome.org/GNOME/libsecret/merge_requests/19)
----
- gkr/gkr-keyring-add.vala | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/gkr/gkr-keyring-add.vala b/gkr/gkr-keyring-add.vala
-index 4e92a520..f60c9a22 100644
---- a/gkr/gkr-keyring-add.vala
-+++ b/gkr/gkr-keyring-add.vala
-@@ -41,8 +41,7 @@ public class Seahorse.Gkr.KeyringAdd : Gtk.Dialog {
- 
-         var cancellable = Dialog.begin_request(this);
-         var service = Backend.instance().service;
--        Secret.Collection.create.begin(service, this.name_entry.text, null,
--                                       Secret.CollectionCreateFlags.COLLECTION_CREATE_NONE,
-+        Secret.Collection.create.begin(service, this.name_entry.text, null, 0,
-                                        cancellable, (obj, res) => {
-             /* Clear the operation without cancelling it since it is complete */
-             Dialog.complete_request(this, false);
--- 
-2.23.0
-