summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-04-17 22:49:15 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-05-12 10:49:46 -0400
commit261dbd9122eff559bc20736676e2d0d42f753cae (patch)
tree16cc852e2d330dc70342e5aa174ff510b430b825
parent00e1ab2c73e7ba2abbb688e88e286aca8b493600 (diff)
downloadguix-261dbd9122eff559bc20736676e2d0d42f753cae.tar.gz
gnu: cogl: Update to 1.22.6.
* gnu/packages/gnome.scm (cogl): Update to 1.22.6.
[native-inputs]: Add xorg-server-for-tests.
[arguments]: Re-enable tests.
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4cfaa2a3a5..1d8636712e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4435,7 +4435,7 @@ throughout GNOME for API documentation).")
 (define-public cogl
   (package
     (name "cogl")
-    (version "1.22.4")
+    (version "1.22.6")
     (source
      (origin
        (method url-fetch)
@@ -4443,14 +4443,14 @@ throughout GNOME for API documentation).")
                            (version-major+minor version) "/"
                            "cogl-" version ".tar.xz"))
        (sha256
-        (base32 "1q0drs82a8f6glg1v29bb6g2nf15fw0rvdx3d0rgcgfarfaby5sj"))))
+        (base32 "0x8v4n61q89qy27v824bqswpz6bmn801403w2q3pa1lcwk9ln4vd"))))
     ;; NOTE: mutter exports a bundled fork of cogl, so when making changes to
     ;; cogl, corresponding changes may be appropriate in mutter as well.
     (build-system gnu-build-system)
     (native-inputs
      `(("glib:bin" ,glib "bin")     ; for glib-mkenums
        ("gobject-introspection" ,gobject-introspection)
-       ;;("xorg-server" ,xorg-server) ; for the test suite
+       ("xorg-server" ,xorg-server-for-tests) ; for the test suite
        ("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("glib" ,glib)
@@ -4478,12 +4478,7 @@ throughout GNOME for API documentation).")
                                (string-append "--with-gl-libname="
                                               (assoc-ref %build-inputs "mesa")
                                               "/lib/libGL.so"))
-       ;; XXX FIXME: All tests fail, with many warnings printed like this:
-       ;;   _FontTransOpen: Unable to Parse address
-       ;;   ${prefix}/share/fonts/X11/misc/
-       #:tests? #f
-       #; #:phases
-       #;
+       #:phases
        (modify-phases %standard-phases
          (add-before 'check 'start-xorg-server
                      (lambda* (#:key inputs #:allow-other-keys)