summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:14:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:30 +0200
commit36ce05ffddc2962f9ba96f0924a37b37f0ea8724 (patch)
tree8355690340b29f0b723e7aaf3c8a5bd3e59f50be
parente003a5f06d7e13e0f2e3796023277d14f845a85e (diff)
downloadguix-36ce05ffddc2962f9ba96f0924a37b37f0ea8724.tar.gz
gnu: Add texlive-latex-fancybox.
* gnu/packages/tex.scm (texlive-latex-fancybox): New variable.
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8486d9e59b..42b5ef274a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1787,6 +1787,40 @@ drivers, and VTeX and pdfTeX.")
 tables to be coloured.")
     (license license:lppl)))
 
+(define-public texlive-latex-fancybox
+  (package
+    (name "texlive-latex-fancybox")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (svn-reference
+                    (url (string-append "svn://www.tug.org/texlive/tags/"
+                                        %texlive-tag "/Master/texmf-dist/"
+                                        "/tex/latex/fancybox"))
+                    (revision %texlive-revision)))
+              (sha256
+               (base32
+                "0smmnaad2q8qwicay1frri990lv65l0k8cwzsvdsyp3jk8kp042w"))))
+    (build-system trivial-build-system)
+    (arguments
+     `(#:modules ((guix build utils))
+       #:builder
+       (begin
+         (use-modules (guix build utils))
+         (let ((target (string-append (assoc-ref %outputs "out")
+                                      "/share/texmf-dist/tex/latex/fancybox")))
+           (mkdir-p target)
+           (copy-recursively (assoc-ref %build-inputs "source") target)
+           #t))))
+    (home-page "http://www.ctan.org/pkg/fancybox")
+    (synopsis "Variants of \\fbox and other games with boxes")
+    (description
+     "This package provides variants of @code{\\fbox}: @code{\\shadowbox},
+@code{\\doublebox}, @code{\\ovalbox}, @code{\\Ovalbox}, with helpful tools for
+using box macros and flexible verbatim macros.  You can box mathematics,
+floats, center, flushleft, and flushright, lists, and pages.")
+    (license license:lppl1.2+)))
+
 (define texlive-texmf
   (package
    (name "texlive-texmf")