summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-10-27 22:24:57 -0500
committerEric Bavier <bavier@member.fsf.org>2019-11-07 08:23:47 -0600
commit4090dcb2b22bf1635e673072dab5bf0a37a5be5e (patch)
tree404072f6399d2aa1744ec4c16debcac2f06ed120
parente57c7dd750e59832a085b8cbae748f5f6f090b5f (diff)
downloadguix-4090dcb2b22bf1635e673072dab5bf0a37a5be5e.tar.gz
gnu: john-the-ripper-jumbo: Enable tests.
* gnu/packages/password-utils.scm (john-the-ripper-jumbo)[arguments]: Remove
'#:tests? #f'.  Add 'check' phase after 'install'.
-rw-r--r--gnu/packages/password-utils.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 955a1a443d..bfd3c25421 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -775,7 +775,6 @@ between hosts and entries in the password store.")
                          (string-prefix? "i686" system)) "sse2")
                     ((string-prefix? "aarch" system) "neon")
                     (else "no")))))
-         #:tests? #f ;tests try to create '.john' in the build user's $HOME
          #:phases
          (modify-phases %standard-phases
            (add-before 'configure 'chdir-src
@@ -821,7 +820,13 @@ between hosts and entries in the password store.")
                                      (find-files "." ".*\\.conf")))
                    (copy-recursively "rules" (string-append datadir "/rules")))
                  (copy-recursively "../doc" docdir)
-                 #t))))))
+                 #t)))
+           (delete 'check) ; Tests need installed .conf files; move after install
+           (add-after 'install 'check
+             (lambda args
+               (setenv "HOME" "/tmp")   ; Some tests need to write to ~/.john
+               (setenv "OMP_NUM_THREADS" (number->string (parallel-job-count)))
+               (apply (assoc-ref %standard-phases 'check) args))))))
       (home-page "http://www.openwall.com/john/")
       (synopsis "Password cracker")
       (description "John the Ripper is a fast password cracker.  Its primary