summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:15:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:31 +0200
commitdf2b9bb4deaae44d9934c1dfb90dcb2bd7f36ffe (patch)
tree4ecbfc957a76c245dc4abc33ec3dce53fc29c35f
parent18ce343773a77b0847e72147b947b25d8b98c8f4 (diff)
downloadguix-df2b9bb4deaae44d9934c1dfb90dcb2bd7f36ffe.tar.gz
gnu: Add texlive-latex-float.
* gnu/packages/tex.scm (texlive-latex-float): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cb56243478..37985f945a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1879,6 +1879,29 @@ verbatim mode; build \"example\" environments (showing both result and
 verbatim source).")
     (license license:lppl1.0+)))
 
+(define-public texlive-latex-float
+  (package
+    (name "texlive-latex-float")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "float"))
+              (sha256
+               (base32
+                "0nbl7wylkv22fcdv4p8byhhj575fli6jnqjpkhrkbv8dzwah84nq"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/float"))
+    (home-page "http://www.ctan.org/pkg/float")
+    (synopsis "Improved interface for floating objects")
+    (description
+     "This package improves the interface for defining floating objects such
+as figures and tables.  It introduces the boxed float, the ruled float and the
+plaintop float.  You can define your own floats and improve the behaviour of
+the old ones.  The package also provides the @code{H} float modifier option of
+the obsolete @code{here} package.  You can select this as automatic default
+with @code{\\floatplacement{figure}{H}}.")
+    (license license:lppl)))
+
 (define texlive-texmf
   (package
    (name "texlive-texmf")