summary refs log tree commit diff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2018-06-14 01:02:01 +0200
committerClément Lassieur <clement@lassieur.org>2018-06-14 08:17:59 +0200
commitf4adbe7405fe9b0b921391b315dde79f1547b921 (patch)
tree006f31e29442c5c329f331b38b03267cf0eea9f0
parent0dc572380bf627863b4f9666cffa1ec50022fb1d (diff)
downloadguix-f4adbe7405fe9b0b921391b315dde79f1547b921.tar.gz
gnu: Add python-tldextract.
* gnu/packages/python.scm (python-tldextract, python2-tldextract): New
variables.
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4b1ea91ae6..21201cc8d1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13658,3 +13658,36 @@ library to allow local filesystem access via file:// URLs.")
 
 (define-public python2-requests-file
   (package-with-python2 python-requests-file))
+
+(define-public python-tldextract
+  (package
+    (name "python-tldextract")
+    (version "2.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "tldextract" version))
+       (sha256
+        (base32
+         "1d5s8v6kpsgazyahflhji1cfdcf89rv7l7z55v774bhzvcjp2y99"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-responses" ,python-responses)))
+    (propagated-inputs
+     `(("python-idna" ,python-idna)
+       ("python-requests" ,python-requests)
+       ("python-requests-file" ,python-requests-file)))
+    (home-page
+     "https://github.com/john-kurkowski/tldextract")
+    (synopsis
+     "Separate the TLD from the registered domain and subdomains of a URL")
+    (description
+     "TLDExtract accurately separates the TLD from the registered domain and
+subdomains of a URL, using the Public Suffix List.  By default, this includes
+the public ICANN TLDs and their exceptions.  It can optionally support the
+Public Suffix List's private domains as well.")
+    (license license:bsd-3)))
+
+(define-public python2-tldextract
+  (package-with-python2 python-tldextract))