summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-20 10:22:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-20 17:02:09 +0200
commit1e3d01dd05f4a06e44a54bb8124e93adf3b8b958 (patch)
treef6e5e9819f5774308f9c71844a6faf27f2adcc46
parent7da529c577915e9257b5a2bfe9445c638ad091d6 (diff)
downloadguix-1e3d01dd05f4a06e44a54bb8124e93adf3b8b958.tar.gz
gnu: r-httpuv: Update to 1.6.6.
* gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch: Replace this patch...
* gnu/packages/patches/r-httpuv-1.6.6-unvendor-libuv.patch: ...with this.
* gnu/local.mk (dist_patch_DATA): Update patch file.
* gnu/packages/cran.scm (r-httpuv): Update to 1.6.6.
[source]: Update patch.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/cran.scm6
-rw-r--r--gnu/packages/patches/r-httpuv-1.6.6-unvendor-libuv.patch (renamed from gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch)13
3 files changed, 11 insertions, 10 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 238fb72bc5..ef1bae5f3c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1774,7 +1774,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/readline-6.2-CVE-2014-2524.patch		\
   %D%/packages/patches/renpy-use-system-fribidi.patch		\
   %D%/packages/patches/reposurgeon-add-missing-docbook-files.patch	\
-  %D%/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch	\
+  %D%/packages/patches/r-httpuv-1.6.6-unvendor-libuv.patch	\
   %D%/packages/patches/ri-li-modernize_cpp.patch		\
   %D%/packages/patches/ripperx-missing-file.patch		\
   %D%/packages/patches/rpcbind-CVE-2017-8779.patch		\
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 75175e39f7..b02200bdc7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2393,16 +2393,16 @@ Zucchini.")
 (define-public r-httpuv
   (package
     (name "r-httpuv")
-    (version "1.6.5")
+    (version "1.6.6")
     (source (origin
               (method url-fetch)
               (uri (cran-uri "httpuv" version))
               (sha256
                (base32
-                "0mlilxh2mlrsbbrncla2rg02crr8nnajv649d8whx7ayr8lkdxpm"))
+                "14qjf7bpl7pay89b7vi2vccl342q8xs6101a9x6qijy54k9myfa1"))
               ;; Unvendor bundled libraries. As of 1.5.4 the vendored libuv
               ;; only contains fixes for building on Solaris.
-              (patches (search-patches "r-httpuv-1.5.5-unvendor-libuv.patch"))
+              (patches (search-patches "r-httpuv-1.6.6-unvendor-libuv.patch"))
               (modules '((guix build utils)))
               ;; Cannot unbundle http-parser, because it contains local
               ;; modifications.
diff --git a/gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch b/gnu/packages/patches/r-httpuv-1.6.6-unvendor-libuv.patch
index 30c6425477..adbacc995f 100644
--- a/gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch
+++ b/gnu/packages/patches/r-httpuv-1.6.6-unvendor-libuv.patch
@@ -1,7 +1,7 @@
 Removes references to bundled libuv.
 
---- a/src/Makevars	2020-07-31 11:53:30.576484531 +0200
-+++ b/src/Makevars	2020-07-31 11:54:19.369863118 +0200
+--- a/src/Makevars	2022-09-19 23:37:55.067810741 +0200
++++ b/src/Makevars	2022-09-19 23:39:20.984859770 +0200
 @@ -5,7 +5,7 @@
  
  UNAME := $(shell uname)
@@ -20,13 +20,12 @@ Removes references to bundled libuv.
  
  # To avoid spurious warnings from `R CMD check --as-cran`, about compiler
  # warning flags like -Werror.
-@@ -43,49 +43,5 @@
+@@ -43,50 +43,4 @@
  # PKG_CPPFLAGS += -D_GLIBCXX_ASSERTIONS
  
  
 -$(SHLIB): libuv/.libs/libuv.a http-parser/http_parser.o sha1/sha1.o base64/base64.o
-+$(SHLIB): http-parser/http_parser.o sha1/sha1.o base64/base64.o
- 
+-
 -# We needed to rename lt~obsolete.m4 because the name causes problems with R
 -# CMD check. Here we rename it back.
 -libuv/m4/lt~obsolete.m4: libuv/m4/lt_obsolete.m4
@@ -59,7 +58,8 @@ Removes references to bundled libuv.
 -		touch aclocal.m4; \
 -		touch -r aclocal.m4 configure Makefile.in; \
 -	else \
--		echo "automake found. Running autogen.sh."; \
+-		echo "automake found. Running autoupdate and autogen.sh."; \
+-		autoupdate; \
 -		sh autogen.sh; \
 -	fi; \
 -	chmod +x configure; \
@@ -71,3 +71,4 @@ Removes references to bundled libuv.
 -
 -clean:
 -	$(MAKE) --directory=libuv distclean
++$(SHLIB): http-parser/http_parser.o sha1/sha1.o base64/base64.o