summary refs log tree commit diff
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-02 09:51:22 +0200
committerChristopher Baines <mail@cbaines.net>2022-09-02 19:48:43 +0100
commit34766a6631c97af0f13af6c16e1c9d26780e5cb5 (patch)
tree33c7a3034674494fa4e854e2f19e3ece5bc32098
parent98d7ffcda683c052ea670ebb8ea3e1e29e7daa37 (diff)
downloadguix-34766a6631c97af0f13af6c16e1c9d26780e5cb5.tar.gz
gnu: Add texlive-latex-newfloat.
* gnu/packages/tex.scm (texlive-latex-newfloat): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1b3c086d54..212c7eb4a9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4954,6 +4954,23 @@ that are compatible with @code{natbib}: @code{plainnat}, @code{unsrtnat},
 designed from the start to be compatible with @code{natbib}.")
     (license license:lppl)))
 
+(define-public texlive-latex-newfloat
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-newfloat"
+              (list "doc/latex/newfloat/"
+                    "tex/latex/newfloat/")
+              (base32 "1047max3li9ni15njgsvc7qglakgrjy2l0s72imgzdmwgb2h8jyf")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/newfloat")
+    (synopsis "Define new floating environments")
+    (description
+     "This package offers the command @code{\\DeclareFloatingEnvironment},
+which the user may use to define new floating environments which behave like
+the LaTeX standard foating environments @code{figure} and @code{table}.")
+    (license license:lppl)))
+
 (define-public texlive-latex-newunicodechar
   (package
     (inherit (simple-texlive-package