summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-26 22:43:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-26 23:22:58 +0200
commit60724d69752b24ab3b6b4501925e62726316d28c (patch)
treeca00a03a95050b4baea528fdd98cf2df77344a2c
parented068b960eeedb92823238783779730319b8ba0e (diff)
downloadguix-60724d69752b24ab3b6b4501925e62726316d28c.tar.gz
gnu: python-pytest: Build with 'bash' instead of 'bash-final'.
Addresses FTBFS after 704243e0c6ec5ac86e2f45aaa469717e60b89124.

* gnu/packages/python.scm (python-pytest)[native-inputs]: Add BASH.
(python-pytest-3.0)[native-inputs]: Inherit.
-rw-r--r--gnu/packages/python.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cbef0e6812..ef7b92bd48 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1877,7 +1877,9 @@ code introspection, and logging.")
     (propagated-inputs
      `(("python-py" ,python-py)))
     (native-inputs
-     `(("python-nose" ,python-nose)
+     `(;; Tests need the "regular" bash since 'bash-final' lacks `compgen`.
+       ("bash" ,bash)
+       ("python-nose" ,python-nose)
        ("python-mock" ,python-mock)))
     (home-page "http://pytest.org")
     (synopsis "Python testing library")
@@ -1914,9 +1916,8 @@ and many external plugins.")
                                line)))
              #t)))))
     (native-inputs
-     `(("python-nose" ,python-nose)
-       ("python-mock" ,python-mock)
-       ("python-hypothesis" ,python-hypothesis)))
+     `(("python-hypothesis" ,python-hypothesis)
+       ,@(package-native-inputs python-pytest)))
     (properties `((python2-variant . ,(delay python2-pytest-3.0))))))
 
 (define-public python2-pytest-3.0