summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-22 22:24:41 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-22 22:24:41 +0100
commit64cb064c0c55f13b53d2d9fa8fc3e8e82888e563 (patch)
tree4f3d4a5d15e3cf441a9c6332173676d21609ae17
parent53088d0045a04b382a18a8fd171bc3e6560c6a06 (diff)
downloadguix-64cb064c0c55f13b53d2d9fa8fc3e8e82888e563.tar.gz
gnu: python-wrapper: Append "-wrapper" to the underlying package name.
Reported by Federico Beffa <beffa@ieee.org>.

* gnu/packages/python.scm (wrap-python3): Change the default value of
'name' to include the name of PYTHON.  This disambiguates between
'python-minimal-wrapper' and 'python-wrapper'.
-rw-r--r--gnu/packages/python.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5880cac099..72a3507d1f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -307,7 +307,9 @@ data types.")
     (inputs `(("openssl" ,openssl)
               ("zlib" ,zlib)))))
 
-(define* (wrap-python3 python #:optional (name "python-wrapper"))
+(define* (wrap-python3 python
+                       #:optional
+                       (name (string-append (package-name python) "-wrapper")))
   (package (inherit python)
     (name name)
     (source #f)