summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoman Scherer <roman.scherer@burningswell.com>2022-12-03 12:14:53 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2022-12-19 19:28:09 +0100
commitd03b6fb0e3f0b81b35a9b35b89c213c144c59fe6 (patch)
tree428b752c6ac1f4f27f4376402c1da0cc9e767f46
parent97ef08c20719b608560dc969549aed220a98f453 (diff)
downloadguix-d03b6fb0e3f0b81b35a9b35b89c213c144c59fe6.tar.gz
gnu: Add libaec.
* gnu/packages/geo.scm (libaec): New variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/geo.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index b3a5c0df3f..c0d5dcf7cd 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -128,6 +128,30 @@
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg))
 
+(define-public libaec
+  (package
+    (name "libaec")
+    (version "1.0.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.dkrz.de/k202009/libaec")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "14myrmmiz9z6wgxqywf3a63cq514vrzsd6z4zvpwigvawlk30iip"))))
+    (build-system cmake-build-system)
+    (home-page "https://gitlab.dkrz.de/k202009/libaec")
+    (synopsis "Adaptive Entropy Coding library")
+    (description "Libaec provides fast lossless compression of 1 up to 32 bit
+wide signed or unsigned integers (samples).  The library achieves best results
+for low entropy data as often encountered in space imaging instrument data or
+numerical model output from weather or climate simulations.  While floating
+point representations are not directly supported, they can also be efficiently
+coded by grouping exponents and mantissa.")
+    (license license:bsd-2)))
+
 (define-public cdo
   (package
     (name "cdo")