summary refs log tree commit diff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2021-11-16 17:36:14 +0100
committerJelle Licht <jlicht@fsfe.org>2021-11-16 17:36:20 +0100
commiteb4edd7fde2e596bc2ec36ee773873722df46234 (patch)
treed79abea6d0b45e44ae585c62abe2df8cacb0c06a
parent7dce1df34b5838f8d8915dab3127a27bbb8a430f (diff)
downloadguix-eb4edd7fde2e596bc2ec36ee773873722df46234.tar.gz
gnu: emacs-flymake-kondor: Update to 0.1.1-0.389b513.
* gnu/packages/emacs-xyz.scm (emacs-flymake-kondor): Update to 0.1.1-0.389b513.
[propagated-inputs]: Remove emacs-flymake-quickdef.
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dddf0588d5..113471ae14 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1634,25 +1634,26 @@ boilerplate code from defining new Flymake backend functions.")
       (license license:gpl3+))))
 
 (define-public emacs-flymake-kondor
-  (package
-    (name "emacs-flymake-kondor")
-    (version "0.0.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/turbo-cafe/flymake-kondor")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0h8dqk35r10pxx2w4swb3kij4y2vi17j9wfk978x8lf0wd3h3hsy"))))
-    (build-system emacs-build-system)
-    (propagated-inputs
-     `(("emacs-flymake-quickdef" ,emacs-flymake-quickdef)))
-    (home-page "https://github.com/turbo-cafe/flymake-kondor")
-    (synopsis "Linter with clj-kondo")
-    (description "This package adds Clojure syntax checker clj-kondo.")
-    (license license:gpl3+)))
+  ;; No tag, version grabbed from source .el file.
+  (let ((commit "389b513c7287ede7a996a3d0db2e84b00772fef5")
+        (revision "0"))
+    (package
+      (name "emacs-flymake-kondor")
+      (version (git-version "0.1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/turbo-cafe/flymake-kondor")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1by6p1j091xk5bfdpbqp7fifjn4rknrbm8r3xjfvpb4xcb19nmig"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/turbo-cafe/flymake-kondor")
+      (synopsis "Linter with clj-kondo")
+      (description "This package adds Clojure syntax checker clj-kondo.")
+      (license license:gpl3+))))
 
 (define-public emacs-flymake-shellcheck
   ;; No tag, version grabbed from source .el file.