summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-16 16:47:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:13 +0200
commitfbdf05b1fcc12233c39db3f90a029df1ff47824d (patch)
treed348957320434e313e22279252591d7bbc9a5423
parent42744c1db68f60ee76da27fdef0e1b57c0032207 (diff)
downloadguix-fbdf05b1fcc12233c39db3f90a029df1ff47824d.tar.gz
gnu: Add r-proc.
* gnu/packages/cran.scm (r-proc): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c36b8b0138..3665e3582e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4787,3 +4787,29 @@ dictionaries in Python but with a purposefully R flavor.  For objects of
 appreciable size, access using hashes outperforms native named lists and
 vectors.")
     (license license:gpl2+)))
+
+(define-public r-proc
+  (package
+    (name "r-proc")
+    (version "1.12.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "pROC" version))
+       (sha256
+        (base32
+         "05ad69a6fxy9k903cw3h4q59ch2jv6qfg9yjdbw3cgiiazcafrlj"))))
+    (properties `((upstream-name . "pROC")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-plyr" ,r-plyr)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "http://expasy.org/tools/pROC/")
+    (synopsis "Display and analyze ROC curves")
+    (description
+     "This package provides tools for visualizing, smoothing and comparing
+receiver operating characteristic (ROC curves).  The area under the
+curve (AUC) can be compared with statistical tests based on U-statistics or
+bootstrap.  Confidence intervals can be computed for (p)AUC or ROC curves.")
+    (license license:gpl3+)))