summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-07-02 21:15:47 +0100
committerChristopher Baines <mail@cbaines.net>2022-07-03 10:11:24 +0100
commit207ef8758ee60148855fea9c4e7d4e4bd825a3ae (patch)
tree184bda3c6f57e5527b8e66be9fd7c5ec2f53514d
parentc145e51844bf52eb77cdc969a0fe30a48755b29e (diff)
downloadguix-207ef8758ee60148855fea9c4e7d4e4bd825a3ae.tar.gz
gnu: java-xpp3: Download source from ci.guix.gnu.org.
The www.extreme.indiana.edu site is now serving a redirect:

  This site has been deprecated. You can access an archive of this site at
  https://web.archive.org/web/20210225153105/https://www.extreme.indiana.edu/.

Because this isn't a 404, as it probably should be, guix follows this redirect
and gets some content that isn't the file it asked for.

To avoid this incorrect behaviour, switch to using a ci.guix.gnu.org URL for
the file instead.

* gnu/packages/xml.scm (java-xpp3)[source]: Switch the uri to ci.guix.gnu.org.
-rw-r--r--gnu/packages/xml.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 0ae51d2e2b..c3213b8f36 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1936,9 +1936,12 @@ validator.")
     (version "1.1.4")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://www.extreme.indiana.edu/dist/"
-                                  "java-repository/xpp3/distributions/xpp3-"
-                                  version "_src.tgz"))
+              (uri (string-append
+                    "https://ci.guix.gnu.org/file/"
+                    "xpp3-1.1.4_src.tgz"
+                    "/sha256/"
+                    "1b99zrhyij5qwyhilyjdl1ykxvhk902vsvflh6gx4fir8hfvdl5p"))
+              (file-name (string-append name "-" version "_src.tgz"))
               (sha256
                (base32
                 "1b99zrhyij5qwyhilyjdl1ykxvhk902vsvflh6gx4fir8hfvdl5p"))