summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:28:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:28:21 +0200
commit35407f948e74fd3ba55541137d47b1ff121baa9a (patch)
tree6fb0570ae06121089a53940bc83ad81e3fcd5375
parent321c73c3873eb14c5efa5f88694685031089c46d (diff)
downloadguix-35407f948e74fd3ba55541137d47b1ff121baa9a.tar.gz
gnu: devhelp: Don't create icon cache.
* gnu/packages/gnome.scm (devhelp)[arguments]: Add phase to skip
creating the gtk icon cache.
[native-inputs]: Remove gtk+:bin.
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 21aad2328a..d9364acd87 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3472,12 +3472,20 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
                (base32
                 "036sddvhs0blqpc2ixmjdl9vxynvkn5jpgn0jxr1fxcm4rh3q07a"))))
     (build-system meson-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson_post_install.py"
+               (("gtk-update-icon-cache") "true"))
+             #t)))))
     (native-inputs
      `(("intltool" ,intltool)
        ("itstool" ,itstool)
        ("gobject-introspection" ,gobject-introspection)
        ("glib:bin" ,glib "bin") ; for glib-mkmenus
-       ("gtk+:bin" ,gtk+ "bin")  ; for gtk-update-icon-cache
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("amtk" ,amtk)