summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-28 01:08:37 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-28 01:08:37 +0100
commit5e4d8f67100d066420e0fe5478f4d4ac62a57bfd (patch)
tree82c7a877dd4a65e25c1429bd48ff2d7d7432b3c6
parent7ca0dbc3f063ef26c6eff87ec9661eab84af5c85 (diff)
downloadguix-5e4d8f67100d066420e0fe5478f4d4ac62a57bfd.tar.gz
gnu: python-numpydoc: Drop one test.
* gnu/packages/python.scm (python-numpydoc): Drop one test for all Python
  versions.
  (python2-numpydoc): Define it by package-with-python2 without modifications.
-rw-r--r--gnu/packages/python.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 014e592203..7c12ebf6d2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2147,7 +2147,15 @@ that client code uses to construct the grammar directly in Python code.")
              version ".tar.gz"))
        (sha256
         (base32
-         "0d4dnifaxkll50jx6czj05y8cb4ny60njd2wz299sj2jxfy51w4k"))))
+         "0d4dnifaxkll50jx6czj05y8cb4ny60njd2wz299sj2jxfy51w4k"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; Drop a test requiring matplotlib, which we cannot add as an
+           ;; input since it would create a circular dependency: Extend the
+           ;; test for Python 3, where it is already dropped, to Python 2.
+           (substitute* "numpydoc/tests/test_plot_directive.py"
+             (("3") "2"))))))
     (build-system python-build-system)
     (inputs
      `(("python-setuptools" ,python-setuptools)
@@ -2162,13 +2170,7 @@ that client code uses to construct the grammar directly in Python code.")
     (license bsd-2)))
 
 (define-public python2-numpydoc
-  (package
-    (inherit (package-with-python2 python-numpydoc))
-    ;; With python-2 1 test (out of 30) fails because it doesn't find
-    ;; matplotlib.  With python-3 it seems to detect at run-time the absence
-    ;; of matplotlib.
-    (arguments `(#:tests? #f
-                 #:python ,python-2))))
+  (package-with-python2 python-numpydoc))
 
 (define-public python-matplotlib
   (package