summary refs log tree commit diff
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-03-27 20:15:04 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-03-27 20:15:04 +0200
commit741916f11457129442c8155d8c55de22112b04c9 (patch)
tree0ced77a5367532919718220044e35b62dc08ff33
parentb5a1359d44a66000267cd648f46ad578890a89f0 (diff)
downloadguix-741916f11457129442c8155d8c55de22112b04c9.tar.gz
gnu: Add libzmf.
* gnu/packages/libreoffice.scm (libzmf): New Variable.
-rw-r--r--gnu/packages/libreoffice.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 52f4266920..760f654cdd 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -629,6 +630,35 @@ spreadsheet documents.")
 Works word processor file format.")
     (license (list mpl2.0 lgpl2.1+)))) ; dual license
 
+(define-public libzmf
+  (package
+   (name "libzmf")
+   (version "0.0.1")
+   (source
+    (origin
+      (method url-fetch)
+      (uri (string-append "http://dev-www.libreoffice.org/src/libzmf/libzmf-"
+                          version ".tar.xz"))
+      (sha256 (base32
+               "0yp5l1b90xim506zmr3ljkn3qkvbc7qk3dnwq1snxdpr57m37xga"))))
+   (build-system gnu-build-system)
+   (inputs
+    `(("boost" ,boost)
+      ("icu4c" ,icu4c)
+      ("libpng" ,libpng)
+      ("librevenge" ,librevenge)
+      ("zlib" ,zlib)))
+    (native-inputs
+     `(("cppunit" ,cppunit)
+       ("doxygen" ,doxygen)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libzmf")
+    (synopsis "Parses file format of Zoner Callisto/Draw documents")
+    (description "Libzmf is a library that parses the file format of Zoner
+Callisto/Draw documents.  Currently it only understands documents created by
+Zoner Draw version 4 and 5.")
+    (license mpl2.0)))
+
 (define-public hunspell
   (package
     (name "hunspell")