summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-13 11:06:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-13 15:04:33 +0300
commit7890ba02df6500b888792f2ab738b97fe3027349 (patch)
tree0241bb7541b1a5745ca993e7fa3f3768f718db00
parent8e7c84feccf9653307de2c3fcfc2c856fe21a97a (diff)
downloadguix-7890ba02df6500b888792f2ab738b97fe3027349.tar.gz
gnu: kleopatra: Allow skipping tests.
* gnu/packages/kde-pim.scm (kleopatra)[arguments]: Have custom 'check
phase honor #:tests?.
-rw-r--r--gnu/packages/kde-pim.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index b5966f0515..87af6b3216 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1017,8 +1017,9 @@ protocol for querying and modifying directory services running over TCP/IP. ")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (invoke "dbus-launch" "ctest" ".")
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "dbus-launch" "ctest" "."))
              #t)))))
     (home-page "https://kde.org/applications/utilities/org.kde.kleopatra")
     (synopsis "Certificate Manager and Unified Crypto GUI")