summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-17 22:04:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-23 20:27:45 +0100
commitc96fcbb1a39aaf39b4cc5e23556981b6e7de1810 (patch)
tree5ee1ff872128592b57427b7465ee5ca077a7bb95
parente84a7f53e7f0167b4df92743221b10a96af6e4f2 (diff)
downloadguix-c96fcbb1a39aaf39b4cc5e23556981b6e7de1810.tar.gz
gnu: ecj-javac-wrapper-final: Use new style for inputs.
* gnu/packages/java.scm (ecj-javac-wrapper-final)[native-inputs]: Use new
style.
-rw-r--r--gnu/packages/java.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ae3888a4ed..07ff449e1c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -778,10 +778,7 @@ machine.")))
 (define ecj-javac-wrapper-final
   (package (inherit ecj-javac-wrapper)
     (native-inputs
-     `(("guile" ,guile-3.0)
-       ("ecj-bootstrap" ,ecj-bootstrap)
-       ("jamvm" ,jamvm)
-       ("classpath" ,classpath-devel)))))
+     (list guile-3.0 ecj-bootstrap jamvm classpath-devel))))
 
 ;; The bootstrap JDK consisting of jamvm, classpath-devel,
 ;; ecj-javac-wrapper-final cannot build Icedtea 2.x directly, because it's