summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-30 00:11:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:46 -0400
commitcdbfe93f164c1621be4e0e0558c3529ff0c720c8 (patch)
tree7473b259f0ea698d7c43232937fb4f55e66d2a8c
parent4e7d6a2dbe74f32fc22bfb2e7a3bbaab7c18cc79 (diff)
downloadguix-cdbfe93f164c1621be4e0e0558c3529ff0c720c8.tar.gz
gnu: Remove python2-pluggy.
* gnu/packages/python-xyz.scm (python2-pluggy): Delete variable.
(python2-pluggy-bootstrap): Likewise.
(python-pluggy)[properties]: Delete field.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b5bebb98c3..74d0e4379c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14565,31 +14565,8 @@ library as well as on the command line.")
    (description "Pluggy is an extraction of the plugin manager as used by
 Pytest but stripped of Pytest specific details.")
    (home-page "https://pypi.org/project/pluggy/")
-   (properties `((python2-variant . ,(delay python2-pluggy))))
    (license license:expat)))
 
-(define-public python2-pluggy
-  (let ((base (package-with-python2 (strip-python2-variant
-                                     python-pluggy))))
-    (package/inherit
-     base
-     (propagated-inputs
-      `(("python-importlib-metadata" ,python2-importlib-metadata))))))
-
-;; This package requires python2-importlib-metadata, but that package
-;; ends up needing python2-pluggy via python2-pytest, so we need this
-;; variant to solve the circular dependency.
-(define-public python2-pluggy-bootstrap
-  (hidden-package
-   (package/inherit
-    python2-pluggy
-    (name "python2-pluggy-bootstrap")
-    (arguments
-     `(#:tests? #f
-       ,@(package-arguments python2-pluggy)))
-    (propagated-inputs
-     `(("python-importlib-metadata" ,python2-importlib-metadata-bootstrap))))))
-
 (define-public python-plumbum
   (package
     (name "python-plumbum")