summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-14 06:55:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-14 06:55:20 +0200
commitf6bc281cd7ffea91764ecfc63aa57b533c884f97 (patch)
treea53e88243bfbcf93f05393ae75e09c65a13c507d
parent5743d505834a8b13778da2c969ea4e15bb7a3a75 (diff)
downloadguix-f6bc281cd7ffea91764ecfc63aa57b533c884f97.tar.gz
gnu: r-tricycle: Move out of annotation packages.
* gnu/packages/bioconductor.scm (r-tricycle): Move definition out of the
section containing annotation packages.
-rw-r--r--gnu/packages/bioconductor.scm74
1 files changed, 37 insertions, 37 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 803437a033..d3b5678343 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -775,43 +775,6 @@ Ensembl.")
 Ensembl.")
     (license license:artistic2.0)))
 
-(define-public r-tricycle
-  (package
-    (name "r-tricycle")
-    (version "1.2.1")
-    (source (origin
-              (method url-fetch)
-              (uri (bioconductor-uri "tricycle" version))
-              (sha256
-               (base32
-                "19yh7yif8630j845m9rddva2z0xy4jcw9j4hvyr076jqbyxz998r"))))
-    (properties `((upstream-name . "tricycle")))
-    (build-system r-build-system)
-    (propagated-inputs (list r-annotationdbi
-                             r-circular
-                             r-dplyr
-                             r-genomicranges
-                             r-ggplot2
-                             r-iranges
-                             r-rcolorbrewer
-                             r-s4vectors
-                             r-scater
-                             r-scattermore
-                             r-singlecellexperiment
-                             r-summarizedexperiment))
-    (native-inputs (list r-knitr))
-    (home-page "https://github.com/hansenlab/tricycle")
-    (synopsis "Transferable representation and inference of cell cycle")
-    (description
-     "The package contains functions to infer and visualize cell cycle process
-using Single-cell RNA-Seq data.  It exploits the idea of transfer learning,
-projecting new data to the previous learned biologically interpretable space.
-The @code{tricycle} provides a pre-learned cell cycle space, which could be
-used to infer cell cycle time of human and mouse single cell samples.  In
-addition, it also offer functions to visualize cell cycle time on different
-embeddings and functions to build new reference.")
-    (license license:gpl3)))
-
 (define-public r-txdb-dmelanogaster-ucsc-dm6-ensgene
   (package
     (name "r-txdb-dmelanogaster-ucsc-dm6-ensgene")
@@ -15424,6 +15387,43 @@ regions) and methods for visualization (e.g., survival plots, volcano plots,
 starburst plots) in order to easily develop complete analysis pipelines.")
     (license license:gpl3+)))
 
+(define-public r-tricycle
+  (package
+    (name "r-tricycle")
+    (version "1.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "tricycle" version))
+              (sha256
+               (base32
+                "19yh7yif8630j845m9rddva2z0xy4jcw9j4hvyr076jqbyxz998r"))))
+    (properties `((upstream-name . "tricycle")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-annotationdbi
+                             r-circular
+                             r-dplyr
+                             r-genomicranges
+                             r-ggplot2
+                             r-iranges
+                             r-rcolorbrewer
+                             r-s4vectors
+                             r-scater
+                             r-scattermore
+                             r-singlecellexperiment
+                             r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/hansenlab/tricycle")
+    (synopsis "Transferable representation and inference of cell cycle")
+    (description
+     "The package contains functions to infer and visualize cell cycle process
+using Single-cell RNA-Seq data.  It exploits the idea of transfer learning,
+projecting new data to the previous learned biologically interpretable space.
+The @code{tricycle} provides a pre-learned cell cycle space, which could be
+used to infer cell cycle time of human and mouse single cell samples.  In
+addition, it also offer functions to visualize cell cycle time on different
+embeddings and functions to build new reference.")
+    (license license:gpl3)))
+
 (define-public r-tximeta
   (package
     (name "r-tximeta")