summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlexandr Vityazev <avityazev@posteo.org>2021-06-03 20:39:32 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-05 13:50:10 +0200
commitfec881eac3b6ad1d3a757544244e6aaff6113706 (patch)
tree7cc971823a8ce1e7bef268dae119aa4aba13e3cb
parentb61ee34c9d7b679cb772e6e8ff0c0876ccf087b1 (diff)
downloadguix-fec881eac3b6ad1d3a757544244e6aaff6113706.tar.gz
gnu: Add emacs-kibit-helper.
* gnu/packages/emacs-xyz.scm (emacs-kibit-helper): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 676b3d35e9..b4a96b28be 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28336,3 +28336,26 @@ shorter than usual, using mostly unprefixed keys.")
    (description "@code{emacs-multitran} is a zero-dependency Emacs interface
 to the https://multitran.com online dictionary.")
    (license license:gpl3+)))
+
+(define-public emacs-kibit-helper
+  (package
+    (name "emacs-kibit-helper")
+    (version "0.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/brunchboy/kibit-helper")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ky167xh1hrmqsldybzjhyqjizgjzs1grn5mf8sm2j9qwcvjw2zv"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-s" ,emacs-s)))
+    (home-page "http://www.github.com/brunchboy/kibit-helper")
+    (synopsis "Use the Kibit Leiningen plugin from Emacs")
+    (description
+     "Kibit Helper provides functions to work with the Kibit Leiningen plugin
+for detecting and improve non-idiomatic Clojure source code.")
+    (license license:gpl3+)))