summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-10-01 05:26:06 -0400
committerLudovic Courtès <ludo@gnu.org>2021-10-30 19:16:23 +0200
commit2339ee166c73055604c9c3770b86f72b04b09ea8 (patch)
tree0a3994b3cd7c923f7cbbd63bb0671f8049d13f62
parenta239b1e678e0c6b21fa95105546e754e2eff8a5d (diff)
downloadguix-2339ee166c73055604c9c3770b86f72b04b09ea8.tar.gz
gnu: Add r-fasterize.
* gnu/packages/cran.scm (r-fasterize): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 792ea2a75b..d1f3e52b1e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -32117,6 +32117,34 @@ Python module, this utility provides a flexible and extensible way of
 formatting and delivering log messages with low overhead.")
     (license license:agpl3+)))
 
+(define-public r-fasterize
+  (package
+    (name "r-fasterize")
+    (version "1.0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "fasterize" version))
+        (sha256
+          (base32 "10bzl77c1b9jhcn1xp467qzp2n8c7s3wpxn53qjh1nwvbri5kd32"))))
+    (properties `((upstream-name . "fasterize")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-raster" ,r-raster)
+        ("r-rcpp" ,r-rcpp)
+        ("r-rcpparmadillo" ,r-rcpparmadillo)
+        ("r-sp" ,r-sp)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/ecohealthalliance/fasterize")
+    (synopsis "Fast Polygon to Raster Conversion")
+    (description
+"This package provides a drop-in replacement for @code{rasterize} from
+the @code{raster} package that takes sf-type objects, and is much faster.
+There is support for the main options provided by the @code{rasterize}
+function, including setting the field used and background value, and
+options for aggregating multi-layer rasters.")
+    (license license:expat)))
+
 (define-public r-ggh4x
   (package
     (name "r-ggh4x")