summary refs log tree commit diff
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-24 15:24:25 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-14 10:27:03 +0100
commit3443942cae47c2c60bed13b37a59a0d0b1a70438 (patch)
treec12acecd47fed720508ee3d507eee7b32aecc34b
parent360d4ebae1f8086515d1bd9e293ae1549b6b7266 (diff)
downloadguix-3443942cae47c2c60bed13b37a59a0d0b1a70438.tar.gz
gnu: Add conflict.
* gnu/packages/shellutils.scm (conflict): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/shellutils.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 7a868f0789..2fe70ffee5 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -543,6 +543,35 @@ site/BBS/person you are giving the information to tries to cross-check the
 city, state, zip, or area code, it will check out.")
     (license license:gpl2+)))
 
+(define-public conflict
+  (package
+    (name "conflict")
+    (version "20210108")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://invisible-mirror.net/archives/conflict/conflict-"
+                    version ".tgz"))
+              (sha256
+               (base32
+                "0mls4climvp7v9hnc3zh01mh270kqcj797ng0xslwb027lipis4h"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda _
+             (substitute* "run_test.sh"
+               (("PATH=\".:\\$BIN:/bin\"")
+                "PATH=\".:$BIN:$PATH\"")))))))
+    (home-page "https://invisible-island.net/conflict/conflict.html")
+    (synopsis "Displays conflicting filenames in your execution path")
+    (description
+     "@code{conflict} examines the user-specifiable list of programs, looking
+for instances in the user's path which conflict (i.e., the name appears in
+more than one point in the path).")
+    (license (license:x11-style "file://COPYING"))))
+
 (define-public renameutils
   (package
     (name "renameutils")