summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-29 20:23:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-29 21:14:39 +0200
commit3af75416e7af3794a201f38b46cd8e20b764321e (patch)
tree8d473b54bf83f0ad83363a139bb2985571528cfb
parent36d6b1ac5f43c3746b73e1cd612ba0cda8cee836 (diff)
downloadguix-3af75416e7af3794a201f38b46cd8e20b764321e.tar.gz
gnu: chroma: Update to 1.19.
* gnu/packages/games.scm (chroma): Update to 1.19.
[arguments]: Remove "CFLAGS=-fgnu89-inline" work-around.
-rw-r--r--gnu/packages/games.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 38852a2874..28443394b7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6414,18 +6414,17 @@ with the mouse isn’t always trivial.")
 (define-public chroma
   (package
     (name "chroma")
-    (version "1.18")
+    (version "1.19")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://level7.org.uk/chroma/download/chroma-"
                                   version ".tar.bz2"))
               (sha256
                (base32
-                "12bjisf5nlqinw8n4r223vld52p0p2mw3fca92vi175c46bycbzn"))))
+                "19ybvv0dkql913xpgjgxyyy50s72vajc7hm83zsvy2lsq8lhg76q"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; no tests included
-       #:configure-flags '("CFLAGS=-fgnu89-inline"))) ; fix inlines
+     `(#:tests? #f))                    ; no tests included
     (inputs
      `(("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
        ("freetype" ,freetype)