summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-09 13:44:12 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-10 11:49:56 +0200
commit47ad589f41c75e63a08937d9149b35a96eed77c6 (patch)
tree6fcfbbd248cdc3ebe83b5fa04312f98f29cf5a92
parent07d859cc064c2bcc2c42884478d40355e815477f (diff)
downloadguix-47ad589f41c75e63a08937d9149b35a96eed77c6.tar.gz
gnu: Add python-bottleneck.
* gnu/packages/python-science.scm (python-bottleneck): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-science.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 88843c1fb2..7675152d79 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -389,6 +389,36 @@ doing practical, real world data analysis in Python.")
                        "if 'NULL byte' in msg or 'line contains NUL' in msg:"))
                     #t)))))))
 
+(define-public python-bottleneck
+  (package
+    (name "python-bottleneck")
+    (version "1.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Bottleneck" version))
+       (sha256
+        (base32 "0wz5320jx3n4q2nsvwvc7cpi66b46qbals9v53m955rmcq5ry5r0"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "python" "setup.py" "pytest"))))))
+    (native-inputs
+     `(("python-hypothesis" ,python-hypothesis)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)))
+    (propagated-inputs
+     `(("python-numpy" ,python-numpy)))
+    (home-page "https://github.com/pydata/bottleneck")
+    (synopsis "Fast NumPy array functions written in C")
+    (description
+     "Bottleneck is a collection of fast, NaN-aware NumPy array functions
+written in C.")
+    (license license:bsd-2)))
+
 (define-public python-xarray
   (package
     (name "python-xarray")