summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:57:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:57:33 +0200
commit67057b1baf9640979d5a230caa0d59ede3829594 (patch)
treef9400915cff134cd80df758c6e4d2e9ae1c86e2b
parent83612310191bd4ea86b37784f7de61d4a8e11e05 (diff)
downloadguix-67057b1baf9640979d5a230caa0d59ede3829594.tar.gz
gnu: emacs-shift-number: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-shift-number)[source]: Download
using git-fetch.
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f124dc3a76..3862cced20 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14276,13 +14276,14 @@ compilation/grep buffers.  Works with @code{wgrep}, @code{ack}, @code{ag},
     (version "0.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/alezost/shift-number.el"
-                           "/archive/" "v" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/alezost/shift-number.el")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1g79m0hqn9jgpm565vvh8pdfzndc4vw7xisnh5qysj55qfg8cb1x"))))
+         "0zlwmzsxkv4mkggylxfx2fkrwgz7dz3zbg2gkn2rxcpy2k2gla64"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/alezost/shift-number.el")
     (synopsis "Increase or decrease the number at point")